手机浏览 RSS 2.0 订阅 膘叔的简单人生 , 腾讯云RDS购买 | 超便宜的Vultr , 注册 | 登陆

App开发者需要更新此App以在此iOS版本上正常工作

首页 > 苹果相关 >

原文来自:https://blog.csdn.net/weixin_43494305/article/details/117958342

---直接粘贴

最近随着iOS隐私协议更新以及iOS14.6系统正式放开,很多已经安装的app在升级到iOS14.6或者iOS15之后在打开App时都会提示“App开发者需要更新此App以在此iOS版本上正常工作 ”,而无法正常使用!此提示是因苹果正版签名(CodeSign)更新所致,导致所有之前macOS11以下系统打包的App在iOS14.6或者iOS15以上的设备会都提示需要更新才能正常工作。

 

解决方法: 

1.首先打包环境 mac升级到macOS11以上,此时打包会采用新的签名机制!

 2.在升级到最新系统之后,重新通过Xcode打包生成新的安装包即可!

 3.对于企业签的App,则需要企业签名提供商签名mac环境同样升级到macOS11系统之上重新签名方可解决。

---SO EASY




本站采用创作共享版权协议, 要求署名、非商业和保持一致. 本站欢迎任何非商业应用的转载, 但须注明出自"膘叔", 保留原始链接, 此外还必须标注原文标题和链接.

« 上一篇 | 下一篇 »

发表评论

评论内容 (必填):