手机浏览 RSS 2.0 订阅 膘叔的简单人生 , 腾讯云RDS购买 | 超便宜的Vultr , 注册 | 登陆

The file or directory to be published does not exist: vendor/bower/jquery/dist

首页 > PHP >

 标题所说的问题可能早期用户都遇到过。但其实这个问题在官方也早就有解决方案了,不知道为什么还有人问起。

这其实是与:fxp/composer-asset-plugin 相关的一个BUG,你在global require的时候,用1.1的beta版就没问题了。
很简单就能发现这个问题了,你先:composer global require "fxp/composer-asset-plugin:~1.1.1",然后composer install就OK了。
其实你如果每次composer update报这个错,你就应该有警惕了:
XML/HTML代码
  1. Deprecation Notice: The Composer\Package\LinkConstraint\MultiConstraint class is deprecated, use Composer\Semver\Constraint\MultiConstraint instead. in phar:///usr/local/bin/compose  
  2. r/src/Composer/Package/LinkConstraint/MultiConstraint.php:17  
  3. Deprecation Notice: The Composer\Package\LinkConstraint\LinkConstraintInterface interface is deprecated, use Composer\Semver\Constraint\ConstraintInterface instead. in phar:///usr/l  
  4. ocal/bin/composer/src/Composer/Package/LinkConstraint/LinkConstraintInterface.php:17  
当然如果你操作完后还是没看到有任何反应,OK,先清除cache......
不多说,Over
 



本站采用创作共享版权协议, 要求署名、非商业和保持一致. 本站欢迎任何非商业应用的转载, 但须注明出自"膘叔", 保留原始链接, 此外还必须标注原文标题和链接.

« 上一篇 | 下一篇 »

发表评论

评论内容 (必填):